WordPress hosting issue
Incident Report for Payment Rails
Resolved
Provider has resolved the issue on their system.
Posted Nov 16, 2020 - 15:29 UTC
Investigating
We are currently investigating this issue.
Posted Nov 16, 2020 - 13:40 UTC
This incident affected: Public Website (www.paymentrails.com).