Whitelabel payment confirmation emails not being sent
Incident Report for Payment Rails
Resolved
This incident has been resolved.
Posted Nov 05, 2020 - 18:50 UTC
Investigating
We are currently investigating this issue.
Posted Nov 04, 2020 - 12:00 UTC
This incident affected: Payment Rails API.